lib7.db error when running calculations

2 posts / 0 new
Last post

I've just created a huge building using Trace700 over the last week. At some point in the making of the file, my Trace program had to be reinstalled due to another error. When I went to run the calculation on the file, I got an error message saying wall constructions and the like are not found and that, "This usually indicates that the trc file was built using a different lib7.db."

I sent an archive of the project to a co worker and it worked for him. I tried running a different Trace file on my own computer and it also worked. It seems like the error is with this file only and only on my PC. Does anybody have any suggestions on how to repair my lib7.db file?

EDIT: Fixed it. I just had to export my library then reinstall Trace.

akingsbury's picture
Joined: 2012-06-11
Reputation: 0

That's what I would've suggested. Nice thinking. There were some other posts about library errors lately.

For future reference - I often make backups of my lib7.db before I do anything.

You can usually "swap them out" and do an export, even if it is an old version of the lib7 file. However, the old version is usually useless for actually operating TRACE. But in my experience, I can usually export from it.  (I know there is a limit on how backwards compatible this would work).

Bob F's picture
eQUEST UserLEED EA Credit 1 TrainingTRACE 700 User
Joined: 2010-06-30
Reputation: 18