error message: "ShellWiz has no valid ZnGrpWiz children." --- too many shells?

9 posts / 0 new
Last post

Dear all

I have been building a model with a large number of shells. I understand
that this is not ideal but I have many overhangs and setbacks.

Once I reach about 60-70 shells a get the following error messages:

"ShellWiz has no valid ZnGrpWiz children."

"Error: No ShellWiz components exist."

"Error creating BDL input file from wizard inputs!"

After these messages the model becomes unusable. Is this likely to be a
shell problem or perhaps something to do with the limitations of running
in wizard mode?

Any suggestions much appreciated.



Richard Williams's picture
Joined: 2011-09-30
Reputation: 0

This sounds like an eQUEST developer question. Hopefully one of them will be
willing/able to take the time to answer it.


cmg750's picture
Joined: 2010-10-05
Reputation: 0

Open up your PD2 file and take a look around - the ZnGrpWiz command
usually follows the Dayshapes/Shapewiz commands for each shell, and
directly precedes definition of the custom zones for the shell.

Look thru each shell, and see if some have them and some don't...I don't
know why eQuest wouldn't automatically define this, but I've
successfully messed around with the PD2 file before without damaging
anything. Make you can copy one of the ZnGrpWiz commands from one shell
to another and make sure to rename accordingly.

Shellwiz is a lot more important: that's the "beginning" of the
definition for each shell. Open up the PD2 file and see if there are
ANY shellwiz definitions, and report back...

GHT Limited
James Hansen, PE, LEED AP

James Hansen's picture
Joined: 2011-09-30
Reputation: 200

I have received this error on several occasions by screwing up the Zone
Group Definitions Screen in the DD Wizard. (Screen 14)

I have never liked eQuest's naming nomenclature, so I have always
renamed zone groups myself so that I can better keep track of what is
what. (e.g.. "Gym" as opposed to "EL1 Ground Floor Core")

If you delete all of the zone groups and then recreate them with your
own name, sometimes I experience being unable to assign the new groups
to spaces. When I click the mouse on a space, a context menu does NOT
appear as it normally does. In this case, I am "stuck" and cannot assign
a zone group to a space.

My experience has been that this error occurs much more commonly if you
have only one or two zone groups to assign to spaces.

Previous uses have already chimed in as to the solution... a manual edit
of the .pd2 file. Just thought I would give some background as to what I
have done in the past to cause the error.


Gary.Schrader at's picture
Joined: 2011-09-30
Reputation: 0

Let's try I don't have much time today..

Never try to name your files in the Wizard, as they will all be erased and substitued with the THX1138 version of language (famous SF movie). And if you try to change the .INP file while still in Wizard mode, they will also be erased.

When you get into the Detailed Edit mode, THEN you can make a space "OFFICE-1" or CLASS-2, versus EL1 Ground Floor Core, as Gary intimated.

Gary, I would need an example of what space you could not rename and reassign. I have always been able to name and reassign spaces, zones, and HVAC systems once in the Detailed Edit mode.

I BELIEVE this naming nomenclature difficulty may be eliminated in the near future...

John R. Aulbach, PE, CEM

John Aulbach's picture
Joined: 2011-09-30
Reputation: 1


You are correct about zone, space, etc. names in the wizard not
transferring to detailed mode. (One of my biggest feature requests)
However, I have found that in many instances I do not need to enter
detailed mode depending upon the complexity of the project. In this
instance, my renaming zone groups inside of the wizard does become
helpful if/when the model needs to be referred to in the future, or when
my models are being QCed.

I have never once had difficulty renaming anything in detailed mode. It
is only on Screen 14 of the DD Wizard that I have encountered the
aforementioned error as a result of deleting out eQuest's default zone
group names. To reiterate, the deletion of all default names prior to my
creating my new ones has generally resulted in a "lock-up" of sorts
inside the wizard resulting in a .pd2 edit.


Gary.Schrader at's picture
Joined: 2011-09-30
Reputation: 0

Thanks for the suggestion.

I have looked through and all the shell definitions seem to be there and
all start with "Shellwiz". Each of them has the "ZnGrpWiz" command.


Richard Williams's picture
Joined: 2011-09-30
Reputation: 0

Sorry, meant to do a reply all.

---------- Forwarded message ----------

cmg750's picture
Joined: 2010-10-05
Reputation: 0

I run into this problem often when modeling mechanical spaces as their own shell. It seems that some of the zoning patterns in the wizard ("one per zone" especially) can not handle some of the custom shapes you may make and will not let you select them in the zone group screen. My solution has been just to select the zone pattern you want, then select "custom", then on the pop up screen select "keep previous zoning pattern", and then hit done when the drawing screen pops up. You can then go to the zone groups screen and be able to select it. This has always worked for me so I think it should solve your error.

John Grando LEED AP| Mechanical Engineer

Grando, John's picture
Joined: 2011-09-30
Reputation: 0